adeptict - Admins may be unable to remove and view the latest status changes of migration batches in Exchange Online – Incident details

Exchange Online experiencing degraded performance

Admins may be unable to remove and view the latest status changes of migration batches in Exchange Online

Resolved
Degraded performance
Started about 2 hours agoLasted 5 minutes

Affected

Cloud Services

Degraded performance from 12:06 PM to 12:12 PM

Office 365

Degraded performance from 12:06 PM to 12:12 PM

SharePoint Online

Degraded performance from 12:06 PM to 12:12 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Admins may be unable to remove and view the latest status changes of migration batches in Exchange Online